WooCommerce

Compatibility

Our plugin, to work properly, must be installed respecting the following minimum requirements:

  • PHP 7.1 or higher
  • WordPress 4.9 or higher
  • WooCommerce 3.0.4 or higher.

Version and support

Currently, the Soisy plugin for WooCommerce is at version 2.0.0.
All previous versions are no longer supported.

Installation

Download the latest version of the Soisy plugin for WooCommerce.

Configuration

Once the plugin is installed, open the page WooCommerce> Settings> Payments> Soisy from the WordPress control panel.
Here is the description of the individual parameters:

  • Enable:

    allows you to enable or disable payment with Soisy

  • Sandbox:

    the sandbox is the test mode. Use it until you put the plugin into production. Find all the info about the sandbox in the dedicated paragraph.

  • Shop ID and API key:

    the plugin needs authentication credentials. When you go into production. you will need to enter your sales channel credentials. When the Sandbox parameter is set toYes, these credentials are ignored and replaced with the testing ones.

Wording and Translations

If it is necessary to change the wording of a sentence or translate it differently, it is possible, using POEdit, to modify the file for the Italian language:

./soisy-woocommerce-plugin/languages/soisy-it_IT.po

and the one for the English language:

./soisy-woocommerce-plugin/languages/soisy-en_EN.po

Modify the number of maximum installments

During checkout, the customer can decide the number of installments related to their order. Soisy offers a range from 3-60 installments.

If you want to reduce the maximum, simply do the following:

  1. Open the file:
    ./wp-content/plugin/soisy-woocommerce-plugin/soisy-lib-php/src/Soisy/Client.php
    
  2. Change, on line 16, the value of the MAX_INSTALMENTS constant, currently valued at 60. Set the desired maximum.